const regex = /(.?)([fds]|(?<!t|^.)r)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.?)([fds]|(?<!t|^.)r)(.*)', 'g')
const str = `d45
f45
s66`;
const subst = `$1$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);