use strict;
my $str = 'd45
f45
s66';
my $regex = qr/(.?)([fds]|(?<!t|^.)r)(.*)/p;
my $subst = '$1$3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";