#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.?)([fds]|(?<!t|^.)r)(.*)"
Local $sString = "d45" & @CRLF & _
"f45" & @CRLF & _
"s66"
Local $sSubst = "$1$3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)