re = /(.?)([fds]|(?<!t|^.)r)(.*)/
str = 'd45
f45
s66'
subst = '$1$3$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result