$re = '/(.?)([fds]|(?<!t|^.)r)(.*)/';
$str = 'd45
f45
s66';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;