using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.?)([fds]|(?<!t|^.)r)(.*)";
string substitution = @"$1$3$2";
string input = @"d45
f45
s66";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}