#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Jones[^0-9]+([0-9]+\.[0-9,]+)"
Local $sString = "<a class="item" href="https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973">" & @CRLF & _
" <span class="bl"></span>" & @CRLF & _
" <span class="name">Dow Jones</span><br>" & @CRLF & _
" <span class="quote">24.324,64 </span><br>" & @CRLF & _
" <span class="change pos">+1,88%</span>" & @CRLF & _
" </a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")