package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Jones[^0-9]+([0-9]+\.[0-9,]+)`)
var str = `<a class="item" href="https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973">
<span class="bl"></span>
<span class="name">Dow Jones</span><br>
<span class="quote">24.324,64 </span><br>
<span class="change pos">+1,88%</span>
</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}