using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Jones[^0-9]+([0-9]+\.[0-9,]+)";
string input = @"<a class=""item"" href=""https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973"">
<span class=""bl""></span>
<span class=""name"">Dow Jones</span><br>
<span class=""quote"">24.324,64 </span><br>
<span class=""change pos"">+1,88%</span>
</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}