# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Jones[^0-9]+([0-9]+\.[0-9,]+)"
test_str = ("<a class=\"item\" href=\"https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973\">\n"
" <span class=\"bl\"></span>\n"
" <span class=\"name\">Dow Jones</span><br>\n"
" <span class=\"quote\">24.324,64 </span><br>\n"
" <span class=\"change pos\">+1,88%</span>\n"
" </a>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.