const regex = /Jones[^0-9]+([0-9]+\.[0-9,]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Jones[^0-9]+([0-9]+\\.[0-9,]+)', 'gm')
const str = `<a class="item" href="https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973">
<span class="bl"></span>
<span class="name">Dow Jones</span><br>
<span class="quote">24.324,64 </span><br>
<span class="change pos">+1,88%</span>
</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}