use strict;
my $str = '<a class="item" href="https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973">
<span class="bl"></span>
<span class="name">Dow Jones</span><br>
<span class="quote">24.324,64 </span><br>
<span class="change pos">+1,88%</span>
</a>';
my $regex = qr/Jones[^0-9]+([0-9]+\.[0-9,]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}