$re = '/Jones[^0-9]+([0-9]+\.[0-9,]+)/m';
$str = '<a class="item" href="https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973">
<span class="bl"></span>
<span class="name">Dow Jones</span><br>
<span class="quote">24.324,64 </span><br>
<span class="change pos">+1,88%</span>
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);