import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Jones[^0-9]+([0-9]+\\.[0-9,]+)";
final String string = "<a class=\"item\" href=\"https://kurse.boerse.ard.de/ard/mobile/kurse_einzelkurs_uebersicht.htn?i=849973\">\n"
+ " <span class=\"bl\"></span>\n"
+ " <span class=\"name\">Dow Jones</span><br>\n"
+ " <span class=\"quote\">24.324,64 </span><br>\n"
+ " <span class=\"change pos\">+1,88%</span>\n"
+ " </a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}