import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)_my-cookie-key\\=([^\\;]+)";
final String string = "_my-cookie-key=expected value; _key2=value 2; key3=value 3;\n"
+ "_key1=value 1; _my-cookie-key=expected value; key3=value 3;\n"
+ "_key1=value 1; key2=value 2; _my-cookie-key=expected value;";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}