const regex = /(?:^|\s)_my-cookie-key\=([^\;]+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)_my-cookie-key\\=([^\\;]+)', 'mg')
const str = `_my-cookie-key=expected value; _key2=value 2; key3=value 3;
_key1=value 1; _my-cookie-key=expected value; key3=value 3;
_key1=value 1; key2=value 2; _my-cookie-key=expected value;`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);