// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^|\s)_my-cookie-key\=([^\;]+)").unwrap();
let string = "_my-cookie-key=expected value; _key2=value 2; key3=value 3;
_key1=value 1; _my-cookie-key=expected value; key3=value 3;
_key1=value 1; key2=value 2; _my-cookie-key=expected value;";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}