# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$/$2|$5,$6|$9,$10/;t' <<< "111111,11111"