import Foundation
let pattern = #"^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"111111,11111"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2|$5,$6|$9,$10"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}