import re
regex = re.compile(r"^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$")
test_str = "111111,11111"
subst = "$2|$5,$6|$9,$10"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)