using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro";
string input = @"<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}