re = /(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro/m
str = '<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end