import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro";
final String string = "<test><micro>\n"
+ "micro\n"
+ "&test;micro\n"
+ "test micro\n"
+ "test <test> test <test>micro\n"
+ "test<te> micro\n"
+ "test<te> test micro\n"
+ "&test;abcmicro\n"
+ "<a><b>micro\n"
+ "<a><b>ab <>micro\n"
+ "&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}