use strict;
my $str = '<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro';
my $regex = qr/(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}