$re = '/(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro/m';
$str = '<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);