#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{"
Local $sString = "public string Foo(string i1, int i2, string Cad_demo){" & @CRLF & _
" var demo = string.Empty;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")