re = /(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{/
str = 'public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end