$re = '/(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{/';
$str = 'public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);