import Foundation
let pattern = #"(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}