using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{";
string input = @"public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}