// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{").unwrap();
let string = "public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}