#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) <a" & @CRLF & _
" \s*(?:(class|href|target)=\"(.*?)\")?" & @CRLF & _
" \s*(?:(class|href|target)=\"(.*?)\")?" & @CRLF & _
" \s*(class|href|target)=\"(.*?)\"" & @CRLF & _
" \s*" & @CRLF & _
" >" & @CRLF & _
" (.*?)" & @CRLF & _
" <\/a>"
Local $sString = "<a href="index.php">cal</a>" & @CRLF & _
"<a class="xxx" href="index.php">cal</a>" & @CRLF & _
"<a class="navbar-brand" href="index.php" target="">cal<span>.net</span></a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")