const regex = / <a
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(class|href|target)=\"(.*?)\"
\s*
>
(.*?)
<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' <a
\\s*(?:(class|href|target)=\\"(.*?)\\")?
\\s*(?:(class|href|target)=\\"(.*?)\\")?
\\s*(class|href|target)=\\"(.*?)\\"
\\s*
>
(.*?)
<\\\/a>', 'g')
const str = `<a href="index.php">cal</a>
<a class="xxx" href="index.php">cal</a>
<a class="navbar-brand" href="index.php" target="">cal<span>.net</span></a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}