import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " <a\n"
+ " \\s*(?:(class|href|target)=\\\"(.*?)\\\")?\n"
+ " \\s*(?:(class|href|target)=\\\"(.*?)\\\")?\n"
+ " \\s*(class|href|target)=\\\"(.*?)\\\"\n"
+ " \\s*\n"
+ " >\n"
+ " (.*?)\n"
+ " <\\/a>";
final String string = "<a href=\"index.php\">cal</a>\n"
+ "<a class=\"xxx\" href=\"index.php\">cal</a>\n"
+ "<a class=\"navbar-brand\" href=\"index.php\" target=\"\">cal<span>.net</span></a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}