// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x) <a
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(class|href|target)=\"(.*?)\"
\s*
>
(.*?)
<\/a>"#).unwrap();
let string = "<a href=\"index.php\">cal</a>
<a class=\"xxx\" href=\"index.php\">cal</a>
<a class=\"navbar-brand\" href=\"index.php\" target=\"\">cal<span>.net</span></a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}