using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" <a
\s*(?:(class|href|target)=\""(.*?)\"")?
\s*(?:(class|href|target)=\""(.*?)\"")?
\s*(class|href|target)=\""(.*?)\""
\s*
>
(.*?)
<\/a>";
string input = @"<a href=""index.php"">cal</a>
<a class=""xxx"" href=""index.php"">cal</a>
<a class=""navbar-brand"" href=""index.php"" target="">cal<span>.net</span></a>
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}