$re = '/ <a
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(class|href|target)=\"(.*?)\"
\s*
>
(.*?)
<\/a>/x';
$str = '<a href="index.php">cal</a>
<a class="xxx" href="index.php">cal</a>
<a class="navbar-brand" href="index.php" target="">cal<span>.net</span></a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);