re = / <a
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(class|href|target)=\"(.*?)\"
\s*
>
(.*?)
<\/a>/x
str = '<a href="index.php">cal</a>
<a class="xxx" href="index.php">cal</a>
<a class="navbar-brand" href="index.php" target="">cal<span>.net</span></a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end