import re
regex = re.compile(r"""
<a
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(?:(class|href|target)=\"(.*?)\")?
\s*(class|href|target)=\"(.*?)\"
\s*
>
(.*?)
<\/a>
""", flags=re.VERBOSE)
test_str = ("<a href=\"index.php\">cal</a>\n"
"<a class=\"xxx\" href=\"index.php\">cal</a>\n"
"<a class=\"navbar-brand\" href=\"index.php\" target=\"\">cal<span>.net</span></a>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")