using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(=\s*""[^="">]*)""([^="">]*)""([^="">]*"")";
string substitution = @"$1'$2'$3";
string input = @"<img src=""../imgTest.jpg"" alt=""Something ""quoted here, or here"">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}