re = /(=\s*"[^=">]*)"([^=">]*)"([^=">]*")/
str = '<img src="../imgTest.jpg" alt="Something "quoted here, or here"">'
subst = '$1\'$2\'$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result