import Foundation
let pattern = #"(=\s*"[^=">]*)"([^=">]*)"([^=">]*")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img src="../imgTest.jpg" alt="Something "quoted here, or here"">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1'$2'$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)