const regex = /(=\s*"[^=">]*)"([^=">]*)"([^=">]*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(=\\s*"[^=">]*)"([^=">]*)"([^=">]*")', 'g')
const str = `<img src="../imgTest.jpg" alt="Something "quoted here, or here"">`;
const subst = `$1'$2'$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);