using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http:|https:)\/\/i\.imgur\.com\/)";
string input = @"https://i.imgur.com/w33xd
https://i.imgur.com/3234z.jpg
http://i.imgur.com/33
http://i.imgur.com/23";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}