const regex = /((http:|https:)\/\/i\.imgur\.com\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http:|https:)\\\/\\\/i\\.imgur\\.com\\\/)', 'g')
const str = `https://i.imgur.com/w33xd
https://i.imgur.com/3234z.jpg
http://i.imgur.com/33
http://i.imgur.com/23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}