$re = '/((http:|https:)\/\/i\.imgur\.com\/)/';
$str = 'https://i.imgur.com/w33xd
https://i.imgur.com/3234z.jpg
http://i.imgur.com/33
http://i.imgur.com/23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);