re = /((http:|https:)\/\/i\.imgur\.com\/)/
str = 'https://i.imgur.com/w33xd
https://i.imgur.com/3234z.jpg
http://i.imgur.com/33
http://i.imgur.com/23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end