#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[a-z])-(?=[a-z])"
Local $sString = "-fjdkls six-nation-golden-cup-award - jfkdl-" & @CRLF & _
"a-b-c-4-_"
Local $sSubst = "\\-/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)