re = /(?<=[a-z])-(?=[a-z])/
str = '-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_'
subst = '\\\\-/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result