using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[a-z])-(?=[a-z])";
string substitution = @"\\-/";
string input = @"-fjdkls six-nation-golden-cup-award - jfkdl-
a-b-c-4-_";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}